vegettoex.com


Just another WordPress site

Problem Solved: Main Rig Working

author Posted by: VegettoEX on date Feb 2nd, 2009 | filed Filed under: Problem Solved

This was a happy weekend.

You can review the situation for yourself in the blog post from last week, but long story short, I accidentally flipped the surge protector off with my main computer hooked up to it, and it wouldn’t boot after that. Thanks to a flurry of recommendations from personal friends as well as all your blog comments, I had a few avenues to go with in terms of problem-solving.

One of the first suggestions was that I might have blown the power supply in the system. I was perhaps a little hasty in messing around with things, but I decided to rip that sucker out before I did anything else. The problem was that once I got it out, I didn’t really know what to do with it! If it was indeed the power supply that was busted, we discovered it would be tricky to replace since it was a proprietary 1000-watt Dell power supply which they did not just sell as a standard replacement part. There were a few on eBay for purchase in the $50-150 range (which isn’t too bad), but I couldn’t really be guaranteed I’d get a solid product that way. Off-the-shelf power supplies wouldn’t be too helpful, since this one had both a 20-pin and 24-pin connector each going into the motherboard (very strange). For a better idea of what I was dealing with, and at Jeff’s suggestion, here’s a comparison between this Dell power supply and a sentinel machine from The Matrix.

cpu_alive_01

Once Jeff and I got the darn thing back into the system and amazingly remembered/figured-out how to rewire the entire thing, the next step was to check the RAM. We took out all 4 GB and planned on going through them to see if any caused the system to crap out during the boot process. Much to our surprise, we got the computer booting right up with one stick of RAM, but with no mouse or keyboard. The boot process informed us that the system configuration had changed, and to either press F1 to continue or F2 to enter the BIOS setup. Well, no keyboard was plugged in. We plugged in the USB keyboard at that point to see if it would let us continue after a button press, but no-go. We held the power to shut the system back down. We then proceeded to put the entire thing back to normal with all 4 GB of RAM and the standard mouse and keyboard combination (though a different USB mouse than I usually use, but this different one actually being the mouse that came with the system in the first place, which I typically have plugged into the Linux system). Ah-HAH! Same result as before, with it immediately shooting to about one-quarter of the way through POST, and with no beeps to indicate any kind of problem. Reusing an image here, but this is what it looked like:

cpu_dead_01

After another hard shutdown, we decided to give it a go with no mouse and keyboard, but keeping the 4 GB of RAM in the system. Much to our delight, we got through the entire boot all the way into Windows! Once we got to the desktop, we plugged in a mouse and shut it down normally. Out of morbid curiosity, I decided to try booting without the Dell USB keyboard, and a cheap ol’ PS/2 GE keyboard that I think we bought at Radio Shack a few years ago (which, again, I typically have plugged into the Linux machine).

cpu_alive_02

Bingo.

For whatever reason, the Dell USB keyboard was preventing the computer from booting.

No, it wasn’t a specific USB port. We tried different ports, and I’m using all of my USB ports for various things right now (other than that Dell keyboard, of course). The only USB issues we ran into were the back six ports not working upon those first couple reboots (only the two on the front of the machine seemed to work). I’ve had this happen to me, and whatever the problem is, it seems to resolve itself. Perhaps it’s a loose cable inside; I dunno. Speaking of loose cables, the only other small matter that we easily corrected was that the top CD/DVD drive didn’t show up in Windows; it was indeed a loose cable. We were trying to figure out what the POST process was telling us when it said “drive two” was missing, but we assumed it meant a hard drive (since “slot two” out of 0, 1, 2, and 3 doesn’t have a SATA drive in there). We quickly realized that was ridiculous, since there was never a hard drive there, and the computer would neither know nor care if a random extra hard drive was or was not there.

All of those little items were corrected, though, and rather quickly at that. With all of those minor issues out of the way (and after copying over Episode #0161 of the Daizenshuu EX podcast, which was being held hostage on one of the hard drives, to three other locations just to put my mind at ease), we figured we may as well just go ahead and install that new video card! Jeff thought it was so new and clean and pretty that we should take a picture of it before tossing it into the mix, so here you go:

cpu_alive_03

That’s an ASUS EN9800GT PCI-Express blah blah blah card. It’s $129.99 on Newegg, has a $25 mail-in rebate, and came with a free copy of Call of Duty: World at War (which I played for approximately sixty seconds in the campaign mode on easy before dying from a grenade, despite there being an indicator on the screen). Anyway, everything’s running silky-smooth now, including Prince of Persia which looks gorgeous. I was also able to finally beat Portal that Saturday evening, with the entire group huddling closer and closer to the screen during that final level and amazing boss battle. Yes, it took me a while. Yes, I’m slow at games. Yes, it was amazing.

I’ve also picked myself up a UPS to put over in the corner with this machine. It was incredibly stupid of me to not have one in the first place, and while it’s unfortunate that I had to deal with the ramifications of my own shenanigans, it at least prompted me to finally take care of it. I actually can’t remember off the top of my head which one I grabbed, but it was one of the “Geek Squad” ones from Best Buy (I’ll update and add in a link later when I’m home).

So there you have it. Problem solved, and I learned a ton of stuff in the process of fixing it all. All this nonsense due to my carelessness… and a keyboard.

… which, by the way, works on the Linux machine perfectly fine and doesn’t prevent it from booting. Rofls.

Professional Podcasting

author Posted by: VegettoEX on date Oct 7th, 2008 | filed Filed under: Nothing In Particular

Yesterday I recorded (and today I edited) my first “professional” podcast… that is, the first episode of the new podcast we are doing at my job. It was incredibly exciting. I got to spend a little money on upgraded equipment from what I own at home (mixer, mics, etc.), get the troops rallied around the concept, develop show outlines and schedules, etc.

As you heard in the first podcast episode of WTF EX, some of the most important things Jeff and I thought were necessary for managing time were bringing in sanity and happiness to that mix. In this particular example, what makes me more happy than anything else is being able to take something I’ve learned and experimented with in my spare time over the last few years and apply it to work. I’m actually making money doing something I love, and on top of that, I’m spreading valuable information that will make the world a better place. I don’t forget for an instant that what I just said doesn’t happen to many people, and I’m incredibly thankful for it.

How about you all? Do you have any life stories / examples of something similar?

(BTW, if you’re reading this blog and haven’t responded saying who you are, you’re obligated to do so!)